A fix has been implemented and we are verifying that everything is working as expected.
Posted Oct 27, 2025 - 13:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 27, 2025 - 12:42 UTC
Investigating
Our technical teams are investigating an issue with Employee Experience dashboards on our HX Platform. Users are seeing error messages when attempting to access reports. We will provide additional updates as more information is known.
Posted Oct 27, 2025 - 12:38 UTC
This incident affected: Employee Experience (Employee Experience).