Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 15, 2025 - 05:00 UTC
Scheduled
The Quality Performer system will be unavailable from 12:01 AM ET to 11:59 PM ET on Monday, December 15, 2025 to update the Quality Performer Servers with the January 2026 regulatory changes.
Posted Dec 10, 2025 - 16:42 UTC
This scheduled maintenance affected: Clinical Excellence (Quality Performer).