Transparency Performance Issue

Incident Report for Press Ganey

Resolved

Transparency application performance has been restored to normal and all pending scheduled reports have been delivered.
Posted Oct 29, 2025 - 01:40 UTC

Update

The Transparency application has continued to perform normally. Scheduled reports have been delivered with the exception of the CPR reports, which are still currently on hold. Our technical team is continuing to work on a solution to allow these reports to be delivered.
Posted Oct 28, 2025 - 21:19 UTC

Monitoring

Our technical team has implemented some changes and we are seeing improved performance. We are continuing to monitor.
Posted Oct 28, 2025 - 16:58 UTC

Investigating

Users may be experiencing slow performance when accessing our Transparency comment approval application. Also, scheduled reports for Transparency, Reputation and Campaigns are on hold until performance is stabilized. Our technical teams are currently working with AWS Support to investigate the issue.
Posted Oct 28, 2025 - 15:50 UTC
This incident affected: Consumer Experience (Campaigns, Reputation, Transparency).