Our Product and Technical teams have confirmed the disruption with Healthgrades integration has been resolved. Review Collection, Profile Collection, and Review Engagement from Healthgrades are all working normally.
Posted Feb 27, 2026 - 14:43 UTC
Investigating
We are currently experiencing a service disruption affecting our integration with Healthgrades. While review publishing remains functional, other features related to collection and profile management are currently slowed or unavailable.
Posted Feb 24, 2026 - 17:43 UTC
This incident affected: Consumer Experience (Listings, Reputation).