NDNQI site technical issues.

Incident Report for Press Ganey

Resolved

We have confirmed the fix was successful. The issues with the NDNQI website have been resolved.
Posted Aug 04, 2026 - 22:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2026 - 22:17 UTC

Update

We are continuing to investigate this issue. This issue is also impacting users attempting to complete the RN Survey.
Posted Aug 04, 2026 - 21:08 UTC

Investigating

Users are experiencing a variety of errors such as 'Failed to route to the requested page' , 'Service Responded with an error - Unknown Error' when submitting data and running reports.
Posted Aug 04, 2026 - 20:35 UTC
This incident affected: Clinical Excellence (NDNQI).