HRP (NextPlane) Performance Degradation.

Incident Report for Press Ganey

Resolved

This incident is confirmed to be resolved.
Posted Aug 10, 2026 - 14:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 10, 2026 - 14:37 UTC

Investigating

We are currently experiencing performance issues with the HRP site. Our development team is actively investigating the matter and working to restore normal performance as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Aug 10, 2026 - 14:29 UTC
This incident affected: Safety & High Reliability (High Reliability Platform).