Patient Experience Online Survey Processing Delays

Incident Report for Press Ganey

Resolved

This incident is resolved. SMS and email survey invitations are being delivered normally.
Posted Apr 17, 2026 - 17:58 UTC

Update

We are seeing online survey delivery and return volumes returning to normal over the last couple of days. Our IT teams are continuing to monitor for any further issues.
Posted Apr 16, 2026 - 14:03 UTC

Update

We are continuing to make progress on sending the backlog of online survey invitations caused by the delays over the weekend. Our IT teams are monitoring closely.
Posted Apr 15, 2026 - 13:53 UTC

Monitoring

We experienced delays that impacted the delivery of SMS and email survey invitations for Patient Experience surveys over the weekend on 4/11 and 4/12. As a result, the volume of survey returns and comments in our PGFusion reporting platforms may be lower than usual for those days. Our IT teams have implemented a fix and are currently monitoring survey processing. We expect there to be an increase in survey returns this week as the backlog of survey invitations continues to catch up.
Posted Apr 14, 2026 - 19:12 UTC
This incident affected: Patient Experience (PGFusion, PGFusion Dashboards, PGFusion Query Tool, PGFusion - Survey Utilities, PGFusion - Completed Surveys, PGFusion - NPS Dashboard).