This incident has been resolved. The intermittent errors are no longer occurring.
Posted Sep 23, 2026 - 19:38 UTC
Monitoring
Our IT teams have implemented multiple fixes Tuesday morning to address these issues. Based on initial results we are no longer experiencing the intermittent error messages. Our IT teams are continuing to monitor throughout the day.
Posted Sep 22, 2026 - 17:11 UTC
Investigating
We are experiencing some intermittent errors within our iRound tool. Users may be encountering occasional errors or slower performance when working with rounds. Our technical teams are investigating this issue and working towards a resolution.
Posted Sep 21, 2026 - 14:47 UTC
This incident affected: Patient Experience (iRound).