Brand Experience - HealthGrades Provider Listings Update Pause

Incident Report for Press Ganey

Resolved

This incident has been resolved. Our Engineering team was able to correct an issue that was causing delays with data delivery to HealthGrades. HealthGrades has confirmed they are receiving data again and are actively processing updates.
Posted Apr 23, 2026 - 20:06 UTC

Investigating

All HealthGrades updates for providers are currently paused. Provider data changes submitted to HealthGrades during this window will not be reflected on HealthGrades profiles until updates are able to resume. There is no impact to existing live provider listings. This data remains visible and unchanged. Our Engineering and Product teams are currently investigating the issue. Additional updates will be provided when more information is available.
Posted Apr 21, 2026 - 18:19 UTC
This incident affected: Brand Experience (Listings).