Crowdsourcing Outage

Incident Report for Press Ganey

Resolved

Our technical team has implemented a fix and the issue is resolved. Users are able to access the Crowdsourcing application again.
Posted Aug 06, 2026 - 16:17 UTC

Update

We are continuing to investigate this issue.
Posted Aug 06, 2026 - 15:34 UTC

Investigating

We are currently experiencing an outage with our Crowdsourcing application. Users are currently unable to access the platform. Our technical teams are investigating the issue.
Posted Aug 06, 2026 - 14:27 UTC
This incident affected: Employee Experience (Employee Experience), Patient Experience (PGFusion), and Crowdsourcing.