Employee Experience Results Dashboard Links Not Available

Incident Report for Press Ganey

Resolved

This incident has been resolved. The Employee Experience results dashboard links are available again.
Posted Sep 16, 2026 - 14:18 UTC

Monitoring

A fix has been implemented and we are monitoring to confirm the issue is resolved.
Posted Sep 16, 2026 - 14:04 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 16, 2026 - 13:44 UTC

Investigating

Employee Experience users are currently seeing a message of "no data to display here" on the landing page when attempting to access their results. Our IT teams are currently investigating this issue.
Posted Sep 16, 2026 - 13:05 UTC
This incident affected: Employee Experience (Employee Experience Dashboards).