PGFusion Data Refresh and Scheduled Report Delay

Incident Report for Press Ganey

Resolved

The data refresh for PGFusion has completed. Data and comments are now available through 2/17/2026 and scheduled reports are being delivered.
Posted Feb 18, 2026 - 15:24 UTC

Identified

The data refresh for PGFusion is in progress and is currently expected to be completed by 11:00 am ET
Posted Feb 18, 2026 - 15:02 UTC

Investigating

We are experiencing a delay in updating Patient Experience survey data for PGFusion reporting. Survey and comment data in PGFusion is currently available through 2/16/2026 returns. Any scheduled Query Tool or Comment Dashboard reports will be delivered when the data refresh has completed. Our IT teams are actively working to update the data.
Posted Feb 18, 2026 - 13:20 UTC
This incident affected: Patient Experience (PGFusion, PGFusion Dashboards, PGFusion Query Tool, PGFusion - Survey Utilities, PGFusion - Completed Surveys, PGFusion - NPS Dashboard).