We are continuing to work on a fix for this issue.
Posted Nov 04, 2025 - 15:06 UTC
Identified
We have identified an issue affecting some client hierarchies within the our HX Foundations application where facilities may appear outside of their correct health system. This is a mapping-only issue and does not impact data integrity, access permissions, or reporting functionality.
Our technical team is actively working to correct the hierarchy mappings to ensure all facilities are accurately aligned with their respective health systems.
Posted Nov 01, 2025 - 14:10 UTC
This incident affected: HX Platform (HX Foundations).