Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 30, 2025 - 07:00 UTC
Scheduled
iRound's next product upgrade will take place on Thursday, October 30th, between 3 and 5am ET. During this scheduled downtime, users will not be able to access iRound to collect or view data. All HL7 ADT Messages will queue during this time and will process in the order received when iRound is back online.
Posted Oct 27, 2025 - 12:16 UTC
This scheduled maintenance affected: Patient Experience (iRound).