Resolved
This incident is confirmed to be resolved. Service has been restored for the HX Platform.
Posted Apr 15, 2026 - 20:30 UTC
Monitoring
The fix has been implemented and the HX Platform is available again. We are continuing to monitor to confirm the issue is resolved.
Posted Apr 15, 2026 - 19:33 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 15, 2026 - 19:11 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 15, 2026 - 18:38 UTC
Identified
The issue has been identified and our IT teams are working on implementing a fix.
Posted Apr 15, 2026 - 18:07 UTC
Investigating
We are currently experiencing an outage with our HX Platform. Users are currently unable to login to applications accessed through the performance.pressganey.com landing page. Our IT teams are currently investigating and working towards a resolution.
Posted Apr 15, 2026 - 17:43 UTC
This incident affected: Clinical Excellence (NDNQI, Nursing Excellence), Brand Experience (Campaigns, DataManager, Directories, Listings, Reputation, Review Publishing, Transparency), HX Platform (HX Action Management for PX, HX Foundations, Patient Journey), Employee Experience (Employee Experience), Patient Experience (iRound, NarrativeDx, PGFusion, PGFusion Dashboards, PGFusion Query Tool, Post-Discharge Calls, User Access Management, PGFusion - Survey Utilities, PGFusion - Completed Surveys, PGFusion - NPS Dashboard, eSurvey Website), and Member Experience (HX Dashboards).