We are no longer experiencing any delays. All files since 5/30 have now been published to My Files and Completed Surveys.
Posted Jun 02, 2026 - 20:49 UTC
Monitoring
We have identified a delay with the process that publishes InfoTurn Results and Bad Address files to PGFusion My Files for Patient Experience uploads. The delay also impact the phone audio files or mail scanned survey images in the Completed Surveys feature. New files have not been published since 5/30. Our IT team has implemented a fix and we are currently monitoring the progress. We currently expect publishing to be caught up by later this afternoon or evening.
Posted Jun 02, 2026 - 18:25 UTC
This incident affected: Patient Experience (PGFusion, PGFusion - Completed Surveys).