Employee Experience - Intermittent Error Messages in Action Planner

Incident Report for Press Ganey

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 20:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 18:32 UTC

Identified

We have identified an issue that is causing intermittent error messages for some Employee Experience users when accessing the Action Planner feature. Our IT team is currently working on a fix for this issue. We will provide additional updates as more information is available.
Posted Jun 02, 2026 - 18:06 UTC
This incident affected: Employee Experience (Employee Experience).