Our technical teams have resolved this issue. The Transparency interface is performing normally.
Posted Oct 27, 2025 - 18:38 UTC
Investigating
The BX Transparency approval interface is down. Our technical teams are currently working with AWS Support to investigate the issue. Clients using Transparency APIs or widgets to power their own sites are not impacted.
Posted Oct 27, 2025 - 18:28 UTC
This incident affected: Consumer Experience (Transparency).